Jelora

Teardown/Démontage/Réparation alimentation de laboratoire HQ-Power PS1503SB

J’avais acheté, en 2008, une petite alimentation de laboratoire 15V/3A dans une boutique d’électronique. C’est une HQ-Power PS1503SB, toujours fabriquée aujourd’hui et qu’on trouve pour 70€. Ce n’est pas une alimentation haut de gamme mais elle fait le boulot.

20170831_141958.jpg
20170831_142057.jpg

Malheureusement, le voltmètre et l’ampèremètre ont lâché depuis. D’abord, ça a été l’ampèremètre dont les segments inférieurs de l’afficheur LCD ne s’affichaient plus puis les puces de chaque module, des ICL7106 [pdf], ont rendu l’âme. J’avais remplacé celle du voltmètre mais son afficheur LCD est mort peu après en m’affichant tout les segments tout le temps. J’avais fini par utiliser cette alimentation que lorsque j’avais besoin d’une tension à la louche. Le reste de l’électronique, la partie alimentation propre, fonctionne toujours très bien.

Mais bon, j’en ai eu marre de la laisser dans cet état et je n’allait pas en acheter une neuve juste pour ça ! J’ai donc tenté de la réparer. Je l’ai donc (ré)ouverte pour l’analyser ! OSEF de la garantie !
 
20170831_143837.jpg
20170831_143859.jpg
20170831_143911.jpg
20170831_144025.jpg
20170831_144051.jpg
20170831_144159.jpg

L’alimentation est organisée en 4 parties :
- le transformateur.
- la carte alimentation sur le coté.
- 2 transistors 2N3055 [pdf] montés sur radiateur à l’arrière.
- la façade avec les potars de réglage et 2 modules voltmètres dont un utilisé comme ampèremètre.


La carte alimentation permet d’obtenir les tensions pour les modules en façade et la tension qu’on veut en sortie.

20170831_144506.jpg

On y trouve beaucoup de composants simples, facilement trouvables et remplaçables :
- LM741 [pdf] : Amplificateur opérationnel
20170831_144522.jpg

- LM324 [pdf] : Quadruple amplificateur opération faible puissance
20170831_144622.jpg

- 7812 et 7809 [pdf] : Régulateurs de tension 12V (7812) et 9V (7809)
20170831_145803.jpg
20170831_145834.jpg
20170831_145920.jpg

- D313 [pdf] : Transistor NPN 60V 3A
20170831_145819.jpg

- Relais 943-1C-12DS [pdf] : Relais 12VDC
20170831_150034.jpg

D’ailleurs, ce dernier m’a toujours intrigué. Quand je dépasse les 7-8V, je l’entend s’activer. Je n’ai jamais cherché plus loin jusqu’au jour où j’ai vu qu’il y avait qu’un seul condensateur 4700µF. UN SEUL ?! Mais comment c’est possible avec une alimentation de 3A ??? J’en aurais mis, au moins 5 ou 6 ! En fait, pour que ça leur coûte moins à produite je suppose, le fabricant a décidé que faire varier la tension redressée non régulée entre 17V et 30V. Lorsqu’on règle l’alimentation en dessus de 7-8V, on a 17V environ dans le condensateur et lorsqu’on passe au dessus de 7-8V, le relais s’enclenche et on a environ 30V dans le condensateur. De ce manière, lors que l’intensité demandé est importante, la variation de tension non régulée est toujours supérieure à 15V. C’est un truc un peu tiré par les cheveux mais ça marche.

20170831_190209.jpg
20170831_190148.jpg


C’est sympa tout ça, mais le vif du sujet : le voltmètre et l’ampèremètre !
Ils s’agit de modules voltmètres avec une puce ICL7106 et un afficheur générique 2,5 digits (2000 points). La seule indication à propos de ces modules est la référence DX61030A, pas de marque.

20170831_170420.jpg
20170831_150435.jpg
20170831_150446.jpg


Vu qu’il a fallait charger les afficheurs LCD et qu’ils ont énormément de pattes, je ne voulais pas me casser la tête et changer tout circuit. Je n’ai trouvé que très peu d’informations dessus, juste des gens qui cherchent à le changer également et ne trouvant pas en remplacement. Bon, ben ... il va falloir dessouder les LCD entièrement à la pompe et à la tresse à dessouder ! J’ai donc commandé 2 afficheurs LCD et 2 ICL7106.

20170831_143702.jpg

Les afficheurs sont soudés à travers une pièce en plastique qui permet d’éviter que l’afficheur ne soit trop appuyé contre la façade une fois le module revissé. Mais le seul moyen que j’ai trouvé pour retirer les afficheurs était de casser ces pièces en plastique, tans pis. Pour retirer chaque afficheur, le plus simple est de couper toutes les pattes et de dessouder tranquillement chaque morceau de patte qui reste.

20170831_150420.jpg
20170831_150539.jpg
20170831_171212.jpg
20170831_152834.jpg

Il faut bien faire attention de repérer la petite bulle sur le coté. Cela permettra de remettre l’afficheur dans le bon sens (c’est mieux).

20170831_152919.jpg

Le module possède un élément de rétroéclairage vert. Il faut donc retirer délicatement le film réfléchissant à l’arrière de l’afficheur neuf.

20170831_152753.jpg
20170831_180437.jpg

Si tout se passe bien, ça une bonne tête ! Par contre, il y a un truc pour lequel j’ai galéré : les pistes ne sont pas très bien collés, du coup, lorsque je dessoudais les morceaux de pattes, certains pistes partait avec. J’ai donc fait quelques réparations de pistes en grattant le vernis.

20170831_181451.jpg
20170831_181515.jpg

Je reconnecte et revisse les 2 modules, j’allume ... pouf ça marche ! Par contre, c’est pas très bien calibré.

20170831_183816.jpg

Le calibrage des modules se fait avec un potentiomètre multi-tour. J’avais dû le triturer lorsque le module était encore en panne cherchant d’où elle pouvait venir.

20170831_183910.jpg
20170831_184105.jpg

Mais ... il y a un truc bizarre. J’ai mis le réglage de tension à fond et je n’ai que 13,8V ? J’avais jamais connecté de voltmètre avant lorsque les modules fonctionnaient. Ce pourrait-il que la calibration de l’alimentation elle-même soit aussi mauvaise ? Je n’ai touché à aucun autre potentiomètre que ceux des modules voltmètre/ampèremètre. Bref... après quelques recherches, en remontant les fils du potentiomètre de réglage de tension, je trouve un autre potentiomètre qui permet de régler la tension maximale à 15V. Ils aurait pu mettre un potentiomètre multi-tour, c’est galère de régler à 15,00V à 0,01V près avec un potentiomètre basique.

20170831_185910.jpg
20170831_190054.jpg

Pour la petite histoire, la valeur maximale du potentiomètre donne une tension à 15,59V.

20170831_185944.jpg

On passe au calibrage du module ampèremètre en appliquant une charge suffisante (à fond quoi ! ^^). Curieusement, cette alimentation à une limite maximale d'intensité à 3,13A. Peut-être qu'il y a un autre potar pour calibrer ça mais pour 130mA en plus on peut laisser ! :)

20170831_200146.jpg
20170831_200218.jpg


Et voilà avec une alimentation qui est repartie !

Ajouter un commentaire

Nom/Pseudo :

*

Email :

Site web :

Commentaire :

*

Vérification:


*